Problems Associated with Old DCC Software

The Distributed Checksum Clearinghouses or DCC is an anti-spam content filter that runs on a variety of operating systems. It has been in use at many sites since 2000. Third parties have been redistributing copies of the DCC software for many years. It is unfortunate and surprising that some of them are still redistributing ancient and obsolete versions that were last current in 2005. It is less surprising that many DCC installations are running old versions.

See the main DCC web page for information about the current version including the license on the current free version. There is also a list of changes.

Finding the Version Number

The version of DCC software on a computer can be determined with the cdcc -V or dccproc -V command.

Operators of DCC servers can use the server status web page to check the version on servers.

The versions of software used by clients (systems using dccproc, dccifd, or dccm to filter spam) of a DCC server can be inferred from the output of the cdcc "clients -V" on the server. The column labeled "v" shows the version of the DCC client-server protocol used by each client of a DCC server. The current protocol is version 10. Clients using protocol version 9 or older should be upgraded. Clients using protocol version 7 or older compute DCC checksums differently than most DCC clients and so can fail to detect bulk mail.

Protocol
Number
DCC
Version
Released
121.3.1472013/06
111.3.1462013/06
101.3.1362011/01
91.3.982008/10
81.3.962008/09
71.3.622007/10
61.3.252006/01
51.3.192005/09
41.3.62005/07

2012

If the cdcc -V command reports a version older than 1.3.144 or 2.3.144, then you are using a version of DCC software released in 2012 or before.

2007

If the cdcc -V command reports a version older than 1.3.80, then you are using a version of DCC software released in 2007 or before. The checksums it computes for some mail messages probably differ from the checksums computed by most DCC installations, and so DCC is less effective for your email.

Versions from 2007 and before have problems talking to DCC servers. They try too hard to recover from network problems and so can trigger the automatic DoS defenses of the public DCC servers. Those defenses start with delaying responses to clients that make too many requests. Eventually requests from troublesome clients are entirely ignored.

2005

If the cdcc -V command reports a version older than 1.3.25, or if cdcc "clients -V". reports that your DCC clients are using version #4 of the DCC client-server protocol, then you are using a version released in 2005 or before.

Upgrading

In theory the shell script in /var/dcc/libexec/updatedcc (or in some installations in /usr/local/etc/libexec/updatedcc, /etc/dcc/libexec/updatedcc, or elsewhere) will fetch, configure, build, install, and restart the DCC software. If necessary, see the main DCC web page for a tarball of the current version.

If your organization has a commercial license, perhaps because it does not qualify for the free license, you must either have your commercial license key in /var/dcc/.updatedcc_pfile or in the shell environment before running updatedcc.

DCC server operators can see which versions other server operators are using on the DCC server status web page.

Contact Vernon Schryver at vjs@rhyolite.com or use the form.

$Date: 2013/07/04 01:46:22 $